Recent Posts

Pages: [1] 2 3 ... 10
1
Support / Re: Server not being updated on ping correctly.
« Last post by Red Squirrel on May 17, 2017, 06:18:45 PM »
Sorry to hear it's not working.  I posted there asking if there is something I can do at my end, but it's odd it would work in windows bot not mono, that should even matter since the end point does not really care what OS is running as long as the packet is being received/sent. 

At some point I want to make a mod that can be downloaded for ServUO/RunUO to make it easier to interface with UO Gateway.

If you do figure it out let me know what you did as it may come in handy if someone else has the issue.  If I had more time I'd try to dive deeper into why it's not working.
2
Support / Re: Server not being updated on ping correctly.
« Last post by UOFans on May 17, 2017, 06:25:28 AM »
Did those edits it didn't work. I think that method is unfortunately too outdated for ServUO. I did the correct edits, recompiled but no luck. I'm so frustrated with this its ridiculous. What sucks is people in the Free shard community 9 times out of 10 withhold information because they see the other person as a "competitor" and it shouldn't be that way. I wish I could find a working fix for this somewhere......  :(
3
Support / Re: Server not being updated on ping correctly.
« Last post by UOFans on May 15, 2017, 06:44:30 PM »
Oo thank you! Haven't done it yet but I plan to try this tonight.
5
Support / Re: Server not being updated on ping correctly.
« Last post by UOFans on May 12, 2017, 02:16:02 AM »
Oh its ServUO running in Mono.  Sorry

Yeah I will double check the previous threads from previous similar issues.
6
Support / Re: Server not being updated on ping correctly.
« Last post by Red Squirrel on May 12, 2017, 02:03:51 AM »
What is the actual software though (ex: RunUo, Sphere?).  You mention Linux, is it RunUO running in Mono?  I have seen some odd network stuff from running in Mono, I can't recall but think someone here did find a fix.

I ran tcpdump on the server and can see some connectivity but no data.  Not sure if support will be able to help but worth a shot, maybe something related to how packets are being processed within the data centre is causing a weird issue.  It is connecting though, so it's not being blocked or anything.
7
Support / Re: Server not being updated on ping correctly.
« Last post by UOFans on May 12, 2017, 01:54:57 AM »
Maybe I should contact host support and ask them what the hellz is going on maybe their specialists will know why this is happening since they know their network better than anybody since it seems like that's why its happening.
8
Support / Re: Server not being updated on ping correctly.
« Last post by UOFans on May 12, 2017, 01:52:26 AM »
Old server was run on : Docker on Ubuntu 14.04 Server (64 bits) (this one updated perfectly)
New server is run on: Ubuntu Server 14.04 "Trusty Tahr" LTS (64 bits)

 :(
9
Support / Re: Server not being updated on ping correctly.
« Last post by Red Squirrel on May 11, 2017, 10:25:46 PM »
Hmm that is odd.  I can telnet to the port, but it should boot me out after a few enters due to invalid packets, it's like if it's accepting connections but not doing anything with them.  What server software are you running?  This is the log on the UOG side:

Code: [Select]
[May-12-2017 01:15:39am] (3)       {UOFans:Test} : prepoll...
[May-12-2017 01:15:39am] (2)    {UOFans:Test} : Starting new thread...
[May-12-2017 01:15:39am] (3)       {UOFans:Test} : thread created
[May-12-2017 01:15:39am] (3)       {UOFans:Test} : Thread Function started
[May-12-2017 01:15:39am] (4)          {UOFans:Test} : Waiting for 29 seconds...
[May-12-2017 01:16:08am] (2)    {UOFans:Test} : Connecting to 144.217.255.43:2590] (Attempt 1)
[May-12-2017 01:16:08am] (3)       {UOFans:Test} : Unable to connect: Host down
[May-12-2017 01:16:08am] (2)    {UOFans:Test} : Connecting to 144.217.255.43:2590] (Attempt 2)
[May-12-2017 01:16:08am] (3)       {UOFans:Test} : Unable to connect: Host down
[May-12-2017 01:16:08am] (3)       {UOFans:Test} : Done polling
[May-12-2017 01:16:08am] (3)       {UOFans:Test} : Thread Function ended
.[May-12-2017 01:16:09am] (2)    {UOFans:Test} : Ending Thread if still active...
[May-12-2017 01:16:09am] (2)    {UOFans:Test} : Thread ended
[May-12-2017 01:16:09am] (2)    {UOFans:Test} : Updating info...
[May-12-2017 01:16:09am] (2)    {UOFans:Test} : Done updating info.
[May-12-2017 01:16:09am] (4)          {UOFans:Test} : Updating graphs...
[May-12-2017 01:16:09am] (4)          {UOFans:Test} : Done updating graphs
[May-12-2017 01:17:50am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : prepoll...
[May-12-2017 01:17:50am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Starting new thread...
[May-12-2017 01:17:50am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : thread created
[May-12-2017 01:17:50am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Thread Function started
[May-12-2017 01:17:50am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Waiting for 1 seconds...
[May-12-2017 01:17:51am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Connecting to 144.217.255.43:2593] (Attempt 1)
[May-12-2017 01:17:51am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Connected, sending stats packet...
.[May-12-2017 01:17:57am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Time out exceeded while waiting for response, will try to parse anyway...
[May-12-2017 01:17:57am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Response receved:
[May-12-2017 01:17:57am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Response receved (Sanitized):
[May-12-2017 01:17:57am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Expected "clients=" in response string not found.  Aboring this shard entry.
[May-12-2017 01:17:57am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Connecting to 144.217.255.43:2593] (Attempt 2)
[May-12-2017 01:17:57am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Connected, sending stats packet...
[May-12-2017 01:18:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Time out exceeded while waiting for response, will try to parse anyway...
[May-12-2017 01:18:02am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Response receved:
[May-12-2017 01:18:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Response receved (Sanitized):
[May-12-2017 01:18:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Expected "clients=" in response string not found.  Aboring this shard entry.
[May-12-2017 01:18:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Done polling
[May-12-2017 01:18:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Thread Function ended
.[May-12-2017 01:18:03am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Ending Thread if still active...
[May-12-2017 01:18:03am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Thread ended
[May-12-2017 01:18:03am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Updating info...
[May-12-2017 01:18:03am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Done updating info.
[May-12-2017 01:18:03am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Updating graphs...
[May-12-2017 01:18:03am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Done updating graphs
[May-12-2017 01:20:42am] (3)       {UOFans:Test} : prepoll...
[May-12-2017 01:20:42am] (2)    {UOFans:Test} : Starting new thread...
[May-12-2017 01:20:42am] (3)       {UOFans:Test} : thread created
[May-12-2017 01:20:42am] (3)       {UOFans:Test} : Thread Function started
[May-12-2017 01:20:42am] (4)          {UOFans:Test} : Waiting for 26 seconds...
[May-12-2017 01:21:08am] (2)    {UOFans:Test} : Connecting to 144.217.255.43:2590] (Attempt 1)
[May-12-2017 01:21:10am] (3)       {UOFans:Test} : Unable to connect: Host down
[May-12-2017 01:21:10am] (2)    {UOFans:Test} : Connecting to 144.217.255.43:2590] (Attempt 2)
[May-12-2017 01:21:10am] (3)       {UOFans:Test} : Unable to connect: Host down
[May-12-2017 01:21:10am] (3)       {UOFans:Test} : Done polling
[May-12-2017 01:21:10am] (3)       {UOFans:Test} : Thread Function ended
.[May-12-2017 01:21:13am] (2)    {UOFans:Test} : Ending Thread if still active...
[May-12-2017 01:21:13am] (2)    {UOFans:Test} : Thread ended
[May-12-2017 01:21:13am] (2)    {UOFans:Test} : Updating info...
[May-12-2017 01:21:13am] (2)    {UOFans:Test} : Done updating info.
[May-12-2017 01:21:13am] (4)          {UOFans:Test} : Updating graphs...
[May-12-2017 01:21:13am] (4)          {UOFans:Test} : Done updating graphs
[May-12-2017 01:22:48am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : prepoll...
[May-12-2017 01:22:48am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Starting new thread...
[May-12-2017 01:22:48am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : thread created
[May-12-2017 01:22:48am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Thread Function started
[May-12-2017 01:22:48am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Waiting for 3 seconds...
[May-12-2017 01:22:51am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Connecting to 144.217.255.43:2593] (Attempt 1)
[May-12-2017 01:22:51am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Connected, sending stats packet...
.[May-12-2017 01:22:56am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Time out exceeded while waiting for response, will try to parse anyway...
[May-12-2017 01:22:56am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Response receved:
[May-12-2017 01:22:56am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Response receved (Sanitized):
[May-12-2017 01:22:56am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Expected "clients=" in response string not found.  Aboring this shard entry.
[May-12-2017 01:22:56am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Connecting to 144.217.255.43:2593] (Attempt 2)
[May-12-2017 01:22:56am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Connected, sending stats packet...
[May-12-2017 01:23:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Time out exceeded while waiting for response, will try to parse anyway...
[May-12-2017 01:23:02am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Response receved:
[May-12-2017 01:23:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Response receved (Sanitized):
[May-12-2017 01:23:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Expected "clients=" in response string not found.  Aboring this shard entry.
[May-12-2017 01:23:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Done polling
[May-12-2017 01:23:02am] (3)       {UOFans [UOR] [DEDICATED SERVER]} : Thread Function ended
.[May-12-2017 01:23:02am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Ending Thread if still active...
[May-12-2017 01:23:02am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Thread ended
[May-12-2017 01:23:02am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Updating info...
[May-12-2017 01:23:02am] (2)    {UOFans [UOR] [DEDICATED SERVER]} : Done updating info.
[May-12-2017 01:23:02am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Updating graphs...
[May-12-2017 01:23:02am] (4)          {UOFans [UOR] [DEDICATED SERVER]} : Done updating graphs



Edit: was looking at wrong logs, here's a snipplet of logs matching your entries.  Figure it might help.

Basically, it looks like your server is not responding to the stats packet, did anything change between the move? Seems odd.

Actually your server is in the same data centre as the UOG server.  I wonder if it's some odd firewall/IDS thing.  It's connecting, but not handling data right, or something.  This is an odd one. 
10
Support / Re: Server not being updated on ping correctly.
« Last post by UOFans on May 11, 2017, 01:11:06 AM »
http://uogateway.com/shard.php?id=1102&act=view
Theres my UOG page for it. I recently deleted the old one and made a new one after I noticed it wasn't updating.


And Yes I did update the serverlist.cs to show the new IP.

I appreciate your response and any help you can offer!
Pages: [1] 2 3 ... 10

This website and service is non profit other than the little revenue received through ads.
Donations are appreciated to help keep this service going.